OpenSUSE 11.0 -> OpenSUSE 11.1 a přechod KDE -> Gnome

Jak jste si jistě všimli, OpenSUSE 11.1 je na světě. Zkusil jsem tedy udělat upgrade na notebooku a trochu jsem narazil.

Upgrade jsem provedl na živém systému následujícím postupem:

  • odstranění zbytečných repozitářů z konfigurace zypperu
  • přidání repository pro OpenSUSE 11.1
  • zypper dup
  • dlouhé čekání – upgrade jsem pustil večer s tím, že to případně proběhne přes noc
  • večer jsem pořešil pár konfliktů, ráno se probudil a systém byl nainstalován. Trochu mi vadí náročnost na /boot v případě že chci víc jader, mám 100MiB /boot, který mi posledníci 10 let stačil i pro jiné distribuce. OpenSUSE mi tam cpalo docela dost věcí, které jsem si ani nevybral, a pořád si stěžovalo že není místo.
  • Po restartu počítače zpanikařilo jádro, že prý nezná formát init ramdisku. Nabootoval jsem tedy ze starého jádra, přegeneroval initrd a po dalším restartu už to bylo OK.
  • Daklší potíž vznikla s nvidií a Xkama, konkrétně display managerem (~kdm, gdm). Xka startují příliš dlouho a kdm, které jsem používal prostě nenaběhlo 🙁 Řešením bylo posunout timeout v KDE, ale moc se mi to nelíbí – pořád čekám na start Xek skoro půl minuty.

Poslední dobou jsem používal jako desktopové prostředí KDE 3.5, nevyužíval jsem většinu funkcí které toto prostředí nabízí – nastavil jsem ho aby se chovalo co nejvíc jako WindowMaker na který jsem zvyklý. KDE jsem nahodil jen k vůli NetworkManageru, který se prostě nedal (a možná ještě nedá) z WindowMakera pohodlně ovládat. Upgrade KDE skončil docela tragicky – vlastní desktopové prostředí fungovalo, ale knetworkmanager a kbluetooth nekomunikovali s dbus či co a prostě po nabootování notebooku bylo potřeba provést restart NetworkManageru a potom jednovlivých KDE udělátek.

Když už jsem dělal ten upgrade a KDE3.5 stejně přestane být v příštích verzích OpenSUSE podporované, zkusil jsem i KDE4. Nejdřív 4.1, ale ta verze prostě nefungovala. Všechno se sekalo, plasma vytěžovala cpu na 100% a každou chvíli padala. Udělal jsem upgrade na KDE4.2 a nepomohl jsem si 🙁 Také mi připadá, že konfigurovatelnost KDE4 je na úrovni Gnome 🙂 takže jsem nakonec zkusil i to Gnome.

V Gnome jsem nic moc nekonfiguroval, jen jsem popřesouval panely, přenastavil si písmo, zvýšil počet pracovních ploch a nastavil si své oblíbené klávesové zkratky. Jediná věc na kteoru jsem nepřišel jak nastavit je zarolování okna pokud na horním pruhu zakroutím myším kolečkem. Ale to se nějak přežije.

Jestli to půjde takhle dál, tak se nakonec zase vrátím k WindowMakeru a statické konfiguraci sítě. Ušetřím si starosti s upgradem a také ušetřím několik GiB místa na disku protože nebudu mít nainstalované žádné „velké“ desktopové prostředí.

Vypadá to, že rodičům nechám na počítačí OpenSUSE 10, které tam je teď a nebudu upgrade prostě řešit. Nechci strávit další den řešením úplných zbytečností.

AoE (ATA over Ethernet) a WiFi?

Změnou providera a tím i technologie použité pro vlastní připojení se mi uvolnilo wifi rozhraní u Asuse WL500g, takže jsem nahodil domácí AP (zabezpečeno WPA-PSK). V síti mám připojený disk přes AoE. Po kabelu vše běhá tak jak má, ale byl jsem zvědav na WiFi. Dopadlo to nad očekávání dobře. Při přechodu z kabelu na wifi spojení jsem měl namountovaný aoe disk a vše přežilo, jen se snížila rychlost přenosu (z 1Gbps ethernet na 54Mbps wifi).

aoe-stat nyní hlásí, že je disk připojen přes wlan0. Rychlost je doclea nízká, ale na koukání na seriály a poslech hudby uložené na tom disku je to dostatečné.

vodik:~ # aoe-stat 
      e0.6       500.107GB  wlan0 up

[tsunami@vodik]$ dd if=/aoe3/thinkvantage.img of=/dev/null bs=1024k count=100
100+0 vstoupivších záznamů
100+0 vystoupivších záznamů
104 857 600 bajtů (105 MB) zkopírováno, 59,4303 s, 1,8 MB/s

Drupal 6

Provedl jsem upgrade Drupalu na verzi 6, bohužel vzaly za své obrázky vkládané pomocí modulu „image“. Všechny jsem je tedy zrušil, stejně jsou k nalezení v galerii na img.zdenda.com.
Jinak dělat upgrade Drupála z 5.14 na 6.8 bez přípravy je pěknej opruz a ne vše funguje jak má. Spousta modulů které používám jsou teprve ve vývoji, některé neexistují pro 6 vůbec 🙁